Problem updating firmware for 737 X products

Early last year I acquired the 737X CDU, MCP and EFIS. I wanted to use this hardware with the iFly B737NG running on P3D. At the time the software for the iFly was not yet ready. I am trying again but first I want to update the firmware. The EFIS and MCDU indicate they are version V1.0.1. The CDU has version V3.0.2A and worked right away at the time.
I clicked on “Firmware Update”, which indicates NO DFU DEVICE DETECTED and next applied the procedure mentioned on your website to do the updates, disconnecting the USB cable and reinserting with AT arm switch held up for MCP or the listed switch for the EFIS. In both cases the lights flash, after which I return to the Status page and click on the text to initiate the firmware update. I quickly see a FLASH rectangle. When clicking on Flash I see a progress line for a few seconds, after which there is a message saying that the update is done and that the hardware is rebooting. However, after this, the status page still shows V1.0.1 for both EFIS and MCP and the units don’tcommunicate with P3D even though the Cockpit-flightsim status page shows that the simsoftware is iFly on P3D. Also tried with MSFS which the bridge software also detects. When I turn any rotary switch like altitude, numbers disaplyed remain at zero and P3d display of corresponding instrument also remains at zero. Using your Test feature reacts correctly when I activate the various switches.
What am I doing wrong?

To solve the current problem, please wait for the update of the bridge software. If you can’t wait, you can use first.

Thank you.